Webex Announcements Disrupted

15 May 2026, 09:24:06 CEST

Resolved
Affected:Webex Calling Services

Resolved — 15 May, 12:03:25 CEST

We have restored system function and are monitoring to confirm full stability.

Investigating — 15 May, 09:24:06 CEST

We are currently investigating issues with announcements and queue greetings on Webex Calling. Some customers may experience difficulties creating or playing announcements. We are working to resolve this as quickly as possible.