Degraded Performance Affecting Webex Customer Assist
Resolved8 May 2026, 12:44:42 CEST
Affected:Webex Calling Services
Resolved — 11 May, 17:32:17 CEST
We have resolved the issue and all affected services are operating normally. We will continue to monitor to ensure stability.
Monitoring — 8 May, 20:53:05 CEST
The issue has been addressed and we are now monitoring systems to confirm stability.
Investigating — 8 May, 12:44:43 CEST
We are currently investigating reports of degraded performance affecting some customers using Webex Customer Assist. Our team is actively looking into the issue to determine the cause. We will provide further updates as more information becomes available.