Webex Control Hub sign in

3 Jun 2026, 15:33:14 CEST

Resolved
Affected:Control Hub

Resolved — 4 Jun, 14:53:36 CEST

The issue has been resolved and affected functionality should now be restored for impacted users. We will continue to monitor to ensure stability.

Identified — 3 Jun, 15:33:14 CEST

Users and administrators are experiencing intermittent failures logging in to the Webex App, Webex Control Hub, and Webex Developer Portal.