Affected:Basic TelephonyDesktop & Mobile ApplicationsCall RecordingFax SystemVoicemailConferencingNotificationsLDAPMicrosoft Teams Integration3rd Party IntegrationCustomer Self Service PortalPlacetel APIPlacetel MobilePartner PortalInternet ConnectivityDevice Provisioning

Resolved — 16 Aug, 18:59:10 CEST

The issue has been resolved. We will continue to monitor to ensure stability.

Monitoring — 16 Aug, 11:46:58 CEST

Cooling has been restored at the affected data centre. We are monitoring the environment closely to confirm stability before returning to full redundancy.

Identified — 15 Aug, 19:28:21 CEST

Cooling restoration is currently underway at the affected data centre. We will provide a further update once this work is complete.

Identified — 15 Aug, 11:43:26 CEST

We are currently experiencing reduced redundancy in our infrastructure following an issue at one of our data centres. Some users may notice degraded performance or intermittent disruptions across affected services. We are actively monitoring the situation and working to restore full redundancy as quickly as possible.