Placetel AI – Post-Processing Emails Partially Disrupted
Resolved29 Jul 2026, 10:36:10 CEST
Affected:Placetel AI
Resolved — 29 Jul, 11:46:10 CEST
The issue has been resolved and email delivery is now operating normally. We will continue to monitor to ensure stability.
Monitoring — 29 Jul, 11:03:15 CEST
We have resolved the underlying issue and are currently delivering the delayed emails - no messages have been lost. We will continue to monitor the situation to ensure full recovery.
Investigating — 29 Jul, 10:36:10 CEST
We are currently investigating an issue where post-processing emails are not being delivered for a subset of customers using Placetel AI. Our team is actively looking into the matter. We will provide further updates as more information becomes available.