Login Issues Affecting Webex Services

21 Aug 2026, 09:32:12 CEST

Resolved
Affected:Webex Calling ServicesDesktop & Phone ApplicationsControl Hub

Resolved — 21 Aug, 10:27:25 CEST

Cisco has identified the issue and implemented a fix. Services are restored.

Investigating — 21 Aug, 09:32:12 CEST

We are currently investigating an issue where some users may experience difficulties logging in to Webex. Our team is actively looking into the matter. We will provide further updates as more information becomes available.